Aide en ligne watchDirectory

Accueil Aide en ligne
Créer une nouvelle Tâche
Exécuter une Tâche
Suivi des Tâches

Extensions

Edition Standard / Professionnelle
Historique des Versions

Rechercher



Essayez la version complète de watchDirectory, gratuitement pendant 30 jours.
Edition Standard: $79 USD / €79
Edition Professional: $149 USD / €149
Acheter!

 

English Helpfile

English Helpfile

German Helpfile

German Helpfile

Spanish Helpfile

Spanish Helpfile


Privacy Policy

Exporter en XML

Tip: importer dans Access

Importer dans Microsoft® Access®

  1. Créer une nouvelle base de données Access
  2. Choisir le menu Fichier -> données externes -> Importer
  3. Dans la boîte de dialogue, sélectionnez XML dans "type de fichiers"
  4. Sélectionnez un fichier XML exporté par le programme de suivi de tâches.

Si vous souhaitez utiliser les données du programme de suivi des tâches dans un autre programme, comme Microsoft® Excel® ou Access®,vous pouvez exporter toutes les données vers un fichier XML. Dans l'écran de Suivi des Tâches pressez CTRL+X ou choisissez le menu Fichier -> Exporter ("File -> Export").

exporter l'historique en fichiers XML

Paramétrages pour exporter en XML

Exporter vers un fichier ("export to file")

Saisissez le nom d'un fichier XML. Si le fichier existe déjà, il sera écrasé.

Exporter seulement la tâche sélectionnée ("Export only the selected task")

Sélectionnez cette option pour exporter la tâche sélectionnée dans l'écran de suivi des tâches. Si vous décochez cette option, toutes les tâches seront exportées.

Exporter tous les lancements ("Export all runs")

Si vous souhaitez exporter tous les lancements des tâches laissez cette option cochée. Lorsque vous décochez cette option, seuls les lancements les plus récents sont exportés.

Exporter les messages ("Export messages")

Sélectionnez cette option pour exporter les messages qui sont disponibles dans la base de données historique. Vous pouvez limiter le type de messages en en désélectionnant certains : les boîtes à cocher debug, info, warn et error.

Exporter chaque tâche vers un fichier ("Export each task to its own file")

Sélectionnez cette option pour créer un fichier XML pour chaque tâche qui est exportée. Si vous saisissez D:\Data\watchdirectory.xml dans la boîte Exporter vers le fichier ("Export to file"), le fichier XML pour la tâche HELLO est écrit dans D:\Data\watchdirectory_HELLO.xml.

Le programme de suivi des tâches crée également un fichier appelé wdexport.xsd dans le répertoire où sont créés les exports. Il s'agit du schéma XML pour les fichiers XML.

exporter avec la ligne de commandes

exporter avec la ligne de commandes

Si vous exportez régulièrement l'historique des tâches, ou si vous souhaitez automatiser l'export avec un script de commandes, vous pouvez utilisez les paramètres de la ligne de commandes. Cela vous offre une manière simple de lancer une transformation XSL à partir des fichiers XML générés.

options supportées en ligne de commandes

Tip: Utiliser les guillemets

mettez les noms longs entre guillemets

Dans une sessionde commandes, si vous saisissez un nom de fichier avec des espaces, assurez-vous d'entourer le nom de "guillemets"!
Incorrect: C:\My Data\Hello World.xml
Correct: "C:\My Data\Hello World.xml"

-exporthistory: C'est une option obligatoire. Si vous n'utilisez pas cette option, le programme de suivi des tâches démarrera en mode normal, vous montrant son écran d'accueil. Il doit donc être la première option de la ligne de commande. Les autres options peuvent être dans n'importe quel ordre.

-file filenameToExportTo: C'est une option obligatoire, et indique au programme de suivi des tâches dans quel fichier il doit exporter. Si le fichier existe déjà il sera écrasé.

-task taskname: C'est une option obligatoire, et indique au programme de suivi des tâches quelle tâche vous voulez exporter. La ligne de commande supporte une tâche à la fois.

-allruns: Cette option optionnelle indique au programme de suivi des tâches d'exporter tous les lancements de la tâche. Si vous n'indiquez pas cette option, seuls les lancements les plus récents seront exportés.

-messages diwe: Cette option optionnelle indique au programme de suivi des tâches d'exporter les messages de la tâche vers un fichier XML. Vous pouvez limiter le nombre et le type de messages qui sont exportés avec un argument supplémentaire. Cet argument est représenté par ces lettres :

S'il n'y a pas d'arguments fournis, par défaut ce sera iwe.

Exemple: exporter le lancement en cours, tous les messages, de la tâche HELLO

"C:\Program Files\watchDirectory\History.exe" -exporthistory -task HELLO -messages diwe -file D:\Export\Hello.xml

Exemple: exporter tous les lancements, mais seulement les messages d'avertissement ("warning") et d'erreur, de la tâche HELLO

"C:\Program Files\watchDirectory\History.exe" -exporthistory -task HELLO -allruns -messages we -file D:\Export\Hello.xml